Job Applications
Incident Report for SmartRecruiters
Resolved
This incident has been resolved.
Posted Oct 28, 2020 - 17:47 UTC
Monitoring
Our team has identified the issue with accessing Job listings and has implemented a fix. We are now monitoring the results.
Posted Oct 28, 2020 - 17:00 UTC
Investigating
We've identified an issue accessing Job listings affecting the ability to apply to Jobs.
Posted Oct 28, 2020 - 16:04 UTC
This incident affected: Career Pages.