Sending offer letters issue
Incident Report for SmartRecruiters
Resolved
The sending offer letters issue which affected SmartRecruiters has been resolved! You can send offer letters using the platform normally. Happy hiring!
Posted over 1 year ago. Dec 14, 2017 - 18:40 UTC
Investigating
We are currently investigating an issue which affects sending offer letters. We will keep you updated. Thank you for your patience
Posted over 1 year ago. Dec 14, 2017 - 17:31 UTC