Multiple pages do not load

Incident Report for SmartRecruiters

Resolved

This incident has now been resolved. We apologise for the inconvenience caused during this period.
Posted Apr 22, 2026 - 15:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 15:11 UTC

Update

We identified an issue with one of our databases and engineering team is performing  an upgrade.

Datacentre: [DCEU/DCNA/DCAU: SmartRecruiters] Prod: [People page]
Next update expected at: 17.50 CET
Posted Apr 22, 2026 - 14:50 UTC

Identified

We have identified a performance issue affecting some users. We are currently working to resolve this and will keep you updated. We appreciate your patience!

Datacentre: [DCEU/DCNA/DCAU: SmartRecruiters] Prod: [People page]

Our next actions: observing the root cause and taking appropriate actions to stabilise the platform

Next update expected at: 5:35 PM CEST
Posted Apr 22, 2026 - 14:37 UTC

Investigating

We are currently investigating an issue affecting performance. Multiple pages (People tab, Job's Applicant tab, etc.). Thank you for your patience.

Datacentre: [DCEU/DCNA/DCAU: SmartRecruiters] Prod: [People page]
Next update expected at: 16.45 CET
Posted Apr 22, 2026 - 13:36 UTC
This incident affected: Recruiter Apps.