System slowness

Incident Report for SmartRecruiters

Resolved

This incident has been resolved.
Posted May 30, 2025 - 14:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 30, 2025 - 14:03 UTC

Investigating

We are experiencing system slowness, particularly on the Job details page. Our teams are currently investigating the issue.
Posted May 30, 2025 - 13:58 UTC
This incident affected: Recruiter Apps.