System Accessibiliy and Performance Issue

Incident Report for SmartRecruiters

Resolved

The root cause has been identified and a fix has been put in place. Our apologies for the inconvenience caused by this incident.
Posted Oct 28, 2025 - 04:01 UTC

Monitoring

A fix has been implemented, and we are actively monitoring to ensure the system is performing as expected.
Posted Oct 28, 2025 - 02:23 UTC

Investigating

We’re currently experiencing system inaccessibility and performance issues, including slowness and occasional errors when loading the UI pages.
Our Engineering Team is actively working to resolve this as quickly as possible.
We sincerely apologize for the inconvenience and appreciate your patience.
Posted Oct 28, 2025 - 00:41 UTC
This incident affected: Recruiter Apps.